9abf06450640b98f2f52bea4b79154b0

SCCM 2012 SP1 Betaでレポートを構成する

SCCM 2012 SP1 Betaにレポートを構成してみました。

基本的にはTechnetに記事があるので、それを読みそのとおりに実行すればOKでした。

  • Configuration Manager のレポート
    • SQL ServerのReporting Serviceを使用する
    • SCCMのサイトシステムの役割の1つとして「レポートサービスポイント」があり、これをインストール、構成する過程でレポートの定義がReporting Serviceに取り込まれる。

上記技術情報にしたがって構成をしてきます。

rsServerConfigurationError

手順通りに進めて行くとReporting Serviceの正常動作を確認する段階で「レポート サーバーで構成エラーが発生しました。 (rsServerConfigurationError)」というエラーが出てしまいました。

このエラーメッセージ自体からは検索すると以下の情報がヒットします。

手動で構成ファイルの編集等はしていないので不思議な現象です。

インスタンスIDの値を元に、Microsoft SQL Server<instance id>Reporting ServicesLogFilesからログファイルを確認すると以下のエラーが発生していました。

 library!ReportServer_0-4!100c!11/22/2012-08:56:19:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.ServerConfigurationErrorException: No DSN present in configuration file, Microsoft.ReportingServices.Diagnostics.Utilities.ServerConfigurationErrorException: レポート サーバーで構成エラーが発生しました。;

検索すると、以下の記事がヒットしました。きちんと構成されていないことが原因のようです。

Reporting Serviceできちんとデータベースが設定されていないことが原因のようですので、修正します。

これで、エラーは改善されました。

 

レポートが表示されない

続けて手順を進めていくと…、レポートサービスポイントの役割をインストールしてもレポートが表示されない現象が発生しました。SCCMは何もなくすんなり行くことが無いですね・・・。

記事中にそのものずばり「レポートサービスポイントのインストールを検証するには」という項目がありますのでそれにしたがって確認します。

 SMS_SRS_REPORTING_POINTコンポーネントでエラーが出ていました。

report server serviceが起動していないと言っています。

でも、サービスは立ち上がってます・・・。

 

<ConfigMgr のインストール パス>Logs にある Srsrp.log ファイルを確認した所以下のようなログが出ていました。

<SMS_SRS_REPORTING_POINT><11-22-2012 11:11:40.285-540><thread=3968 (0xF80)> Timed Out…~  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.285-540><thread=3968 (0xF80)> Reporting Services URL from Registry [http://stccm1/ReportServer/ReportService2005.asmx]~  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.298-540><thread=3968 (0xF80)> HTTP ステータス 401: Unauthorized で要求が失敗しました。  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.301-540><thread=3968 (0xF80)> (!) SRS not detected as running  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.301-540><thread=3968 (0xF80)> Failures reported during periodic health check by the SRS Server stccm1.stc.local.~  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.301-540><thread=3968 (0xF80)> ~Waiting for changes for 1 minutes  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:12:40.302-540><thread=3968 (0xF80)>

401 Unauthorizedでアクセス出来ず、それによってサービスが実行されていないという判断になってしまっているようです。

現在は全てNETWORKSERVICEで構成しているのですが、それではダメなのでしょうかね?


reporting error

上記の情報があったのでSP2を最適用してみました。たしかにSP2適用後にReporting Serviceをインストールしている環境です。

結果、以下のように正常にアクセス出来るようになりました。

Root Folder exists  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:42:49.147-540><thread=3968 (0xF80)> Successfully checked that the SRS web service is healthy on server stccm1.stc.local~  $$<SMS_SRS_REPORTING_POINT><11-22-2012 11:42:49.148-540><thread=3968 (0xF80)>

そしてレポートも出てきました。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です