image

Orchestratorの「.NETスクリプトの実行」アクティビティ内で最新のバージョンのPowerShellを利用する

Orchestratorの「.NETスクリプトの実行」アクティビティ内でPowerShellスクリプトを実行した際には、古いバージョンのPowerShell環境が立ち上がります。このせいで、「手で動かしたら動くのに、OrchestratorのRunbookにしたら動かない!」という状況が発生します。

回避策として以下のレジストリ設定をOrchestratorサーバー上で行うことで最新バージョンのPowerShell環境にて動作させることができるようになります。

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework

OnlyUseLatestCLR DWORD 1

image

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です